Технический форум
Вернуться   Технический форум > Программирование > Форум программистов > Помощь студентам


Ответ
 
Опции темы Опции просмотра
Старый 03.03.2011, 19:47   #1 (permalink)
Karol
Новичок
 
Регистрация: 03.03.2011
Сообщений: 1
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Репутация: 10
По умолчанию Блок-схема по коду программы 1С

Есть код программы по автоматическому формированию счетов-фактур в программе 1С: бухгалтерия. В форму вводятся дата от и до и запускается процесс по формированию счетов. Необходимо нарисовать блок-схему этой программы, надеюсь кто-нибудь такое умеет делать, вроде это не сложно)

Автоматическое формирование счетов фактур на аванс
//*******************************************
Процедура Сформировать()
СчФ = СоздатьОбъект("Документ.СчетФактура");
СчФ.ИспользоватьЖурнал("СФ_Выданные",0);
Опер = СоздатьОбъект("Операция");
Опер.ВыбратьОперацииСПроводками(ДатаНачала,ДатаКон ца);
Пока Опер.ПолучитьПроводку() = 1 Цикл
ДокОсн = Опер.Документ;
Если ДокОсн.Вид() = "Выписка" Тогда
Если (Опер.Кредит.Счет = СчетПоКоду("62.2")) ИЛИ (Опер.Кредит.Счет = СчетПоКоду("62.5")) Тогда
Контрагент = Опер.Кредит.Контрагенты;
Договор = Опер.Кредит.Договоры;
Сумма = Опер.Сумма;
ПервичныйДокумент = СокРЛП(Опер.ПервичныйДокумент);
НомерСтрокиДокумента = Опер.НомерСтрокиДокумента();
ПлатежныйДокумент = ПервичныйДокумент;
ПозицияНомера = Найти(ПлатежныйДокумент,"№");
НП = СокрЛП(Сред(ПлатежныйДокумент,(ПозицияНомера + 1), СтрДлина(ПлатежныйДокумент) - ПозицияНомера));
ДП = Дата(Лев(ПлатежныйДокумент, (ПозицияНомера - 2)));
СчФ.Новый();
СчФ.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыВыданного.Ава нс;
СчФ.ДокументОснование = ДокОсн.ТекущийДокумент();
СчФ.ДатаДок = Опер.ДатаОперации;
СчФ.ВерсияОбъекта = Константа.НомерРелиза;
Нот = Найти(СокрЛП(Договор),"от");
Нот = Нот - 2;
СчФ.НомерДок = "А" + Лев(СокрЛП(Договор),Нот) + "/" + Формат(ДатаМесяц(Опер.ДатаОперации),"Ч(0)2");
СчФ.Договор = Договор;
СчФ.Контрагент = Контрагент;
СчФ.Грузополучатель = Контрагент;
СчФ.ВключатьВКнигуПродаж = 1;
СчФ.Аванс = 1;
СчФ.ВариантОтправки = 1;
СчФ.НомерПлатРасчДок = НП;
СчФ.ДатаПлатРасчДок = ДП;
СчФ.ДатаОплаты = Формат(ДП,"Д");
/***********************
СчФ.НоваяСтрока();
СчФ.НазначитьТип("Товар","Строка", 22);
СчФ.Товар = "Предварительная оплата";
СчФ.СтавкаНДС = глЗначениеПоУмолчанию("ОсновнаяСтавкаНДС");
СчФ.Цена = Сумма;
СчФ.Сумма = Сумма;
СчФ.Всего = Сумма;
СчФ.СтранаПроисхождения = "";
СчФ.ГТД = "";
СчФ.НДС = Окр(Сумма*18/118,2,1);
СчФ.Записать();
СчФ.Провести(0,"Программно");
КонецЕсли;
КонецЕсли;
ДП = '00.00.00';
НП = "";
КонецЦикла;
Сообщить("ВЫПОЛНЕНО");
КонецПроцедуры
Karol вне форума   Ответить с цитированием

Старый 03.03.2011, 19:47
Helpmaster
Member
 
Аватар для Helpmaster
 
Регистрация: 08.03.2016
Сообщений: 0

Эти топики очень похожи на ваш и помогут вам разобраться

Блок-схема. Паскаль
Нужна блок-схема
Нужна помощь по блок-схеме и в отладке программы

Ads

Яндекс

Member
 
Регистрация: 31.10.2006
Сообщений: 40200
Записей в дневнике: 0
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Репутация: 55070
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Выкл.
HTML код Выкл.
Trackbacks are Вкл.
Pingbacks are Вкл.
Refbacks are Выкл.




Часовой пояс GMT +4, время: 14:01.

Powered by vBulletin® Version 6.2.5.
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.